From Fedora Project Wiki
(facepalm (correct the new package name))
 
Line 62: Line 62:
 
We need to start a new review process and get the latest version of the library to Fedora. Since the update will be backwards incompatible, we need to make sure that all the software requiring this library works with it.
 
We need to start a new review process and get the latest version of the library to Fedora. Since the update will be backwards incompatible, we need to make sure that all the software requiring this library works with it.
  
The name of the package is now <code>docker-python</code>. Here is a [https://bugzilla.redhat.com/show_bug.cgi?id=1422198 link] to the review bug.
+
The name of the package is now <code>python-docker</code>. Here is a [https://bugzilla.redhat.com/show_bug.cgi?id=1422198 link] to the review bug.
  
 
== Benefit to Fedora ==
 
== Benefit to Fedora ==

Latest revision as of 14:31, 23 August 2017


Docker SDK for Python, version 2

Summary

Add new version of "Docker SDK for Python" to Fedora. This obsoletes existing python-docker-py package.

Owner

Current status

Detailed Description

On December 2016, upstream released a new version of python library which communicates with Docker engine API. This new release is not backwards compatible with previous 1.x series. As part of this release, the upstream also renamed the package: it used to be named docker-py on PyPI, now it's named docker.

We need to start a new review process and get the latest version of the library to Fedora. Since the update will be backwards incompatible, we need to make sure that all the software requiring this library works with it.

The name of the package is now python-docker. Here is a link to the review bug.

Benefit to Fedora

docker-compose requires the newest version of the library. So in order to have the latest & greatest software from Docker Inc., we need to do this update.


Scope

  • Proposal owners:
    • Submit a review (done)
    • Do a production build (done)
    • Make sure that all the dependencies work with the updated package (done for atomic, docker-compose, sen)
  • Other developers: N/A (not a System Wide Change)
  • Release engineering: N/A
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

This change will probably affect some users since it is backwards incompatible. Previous version will be available for some time (Fedora 27), then it will be deprecated and only version 2 will remain.

How To Test

  • Install docker-compose-1.11 and test if it works.
  • Install atomic and test if it works.

User Experience

N/A (not a System Wide Change)

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: N/A (not a System Wide Change)
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? N/A (not a System Wide Change), Yes/No
  • Blocks product? N/A

Documentation

N/A (not a System Wide Change)

Release Notes