From Fedora Project Wiki
m (typo)
(Erlang updated)
Line 57: Line 57:
 
== Scope ==
 
== Scope ==
 
* Proposal owners:
 
* Proposal owners:
** [https://bugzilla.redhat.com/1807897 Upgrade Erlang to the latest version (23.0)].
+
** <s>[https://bugzilla.redhat.com/1807897 Upgrade Erlang to the latest version (23.0)]</s>. Done.
 
** We must rebuild every package which requires NIF version (listed below in the [[#Dependencies|Dependencies]] section) against Erlang 23.x.y.
 
** We must rebuild every package which requires NIF version (listed below in the [[#Dependencies|Dependencies]] section) against Erlang 23.x.y.
 
** Every Erlang daemon's systemd unit must require epmd.socket.
 
** Every Erlang daemon's systemd unit must require epmd.socket.

Revision as of 14:00, 20 April 2020

Erlang 23

Summary

Update Erlang/OTP to version 23.

Owner

Current status

  • Targeted release: Fedora 33
  • Last updated: 2020-04-13
  • Tracker bug: []
  • Release Notes tracker: []

Detailed Description

Upgrade Erlang to version 23 which brings a lot of changes. Just a few highlights:

  • Numerous scalability and performance improvements.
  • New modules - pg (pool group) and erpc (enhanced RPC).
  • Removed SSL 3.0 support entirely.
  • Removed deprecated part of erl_interface API
  • An experimental socket backend for TCP and UDP API.
  • Even faster SSL/TLS operations.
  • Now it's possible to work w/o external EPMD in production-ready applications

Aside from this, we plan to improve quality of Erlang and related packages. These are shortcomings we want to address: Besides that we still have a lengthy list of TODOs:

  • Every daemon written in Erlang has its own logging solution which doesn't use neither syslog nor Journald. We should start switching them to unified logger..
  • We should allow D-Bus API via erlang-dbus library or any other recent implementations..
  • Further improve Erlang Packaging Guidelines and promote it as the official guideline.
  • Switch to rebar3 as a main build tool.
  • SELinux rules for main Erlang applications (Ejabberd, CouchDB, RabbitMQ) are outdated or missing.

Benefit to Fedora

Fedora users, both developers and end-users, will have visible benefits from using Fedora-provided packages. Namely:

  • Improved scalability and robustness.

Scope

  • Proposal owners:
  • Other developers: N/A
  • Release engineering: TBA
  • Policies and guidelines:
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

  • Every Erlang upgrade requires the rebuilding of modules which contains ports or NIFs, and we will rebuild all such modules in Fedora. However if a user has some additional modules not available in a Fedora repository, then these modules must be rebuilt manually.
  • So-called HiPE continues to deteriorate. In this version it's barely functional and likely is going to be removed in the next one.

How To Test

  • Ensure that high-grade Erlang applications are still working:
Name Tested
Package-x-generic-16.pngcouchdb No
Package-x-generic-16.pngejabberd No
Package-x-generic-16.pngelixir No
Package-x-generic-16.pngrabbitmq-server No
Package-x-generic-16.pngriak No (package was retired :( )
Package-x-generic-16.pngwings No
  • Collect feedback from volunteers regarding their experience with this Erlang/OTP version

User Experience

Users will get more robust, scalable, and fast Erlang applications.

Dependencies

The following packages must be rebuilt:

Name Rebuilt
Package-x-generic-16.pngcouchdb No
Package-x-generic-16.pngerlang-basho_metrics No
Package-x-generic-16.pngerlang-bitcask No
Package-x-generic-16.pngerlang-cache_tab No
Package-x-generic-16.pngerlang-cl No
Package-x-generic-16.pngerlang-ebloom No
Package-x-generic-16.pngerlang-eleveldb No
Package-x-generic-16.pngerlang-emmap No
Package-x-generic-16.pngerlang-erlsyslog No
Package-x-generic-16.pngerlang-esasl No
Package-x-generic-16.pngerlang-esdl No
Package-x-generic-16.pngerlang-esip No
Package-x-generic-16.pngerlang-fast_tls No
Package-x-generic-16.pngerlang-fast_xml No
Package-x-generic-16.pngerlang-fast_yaml No
Package-x-generic-16.pngerlang-hyper No
Package-x-generic-16.pngerlang-iconv No
Package-x-generic-16.pngerlang-jiffy No
Package-x-generic-16.pngerlang-js No
Package-x-generic-16.pngerlang-lfe No
Package-x-generic-16.pngerlang-riak_ensemble No
Package-x-generic-16.pngerlang-sd_notify No
Package-x-generic-16.pngerlang-skerl No
Package-x-generic-16.pngerlang-snappy No
Package-x-generic-16.pngerlang-stringprep No
Package-x-generic-16.pngerlang-xmpp No

Contingency Plan

  • Contingency mechanism: None necessary. Instead of falling back to the previous version we should fix existing packages in order to help the Community. We should also monitor upstream development process for potentially discovered issues and proactively apply patches (as we already did with Erlang R14, Erlang R15, Erlang R16, Erlang 17, Erlang 18, Erlang 19, Erlang 20, Erlang 21 and Erlang 22). It should be noted that this change consists from an independent or loosely coupled smaller changes. If we fail to deliver some changes in time, we should reschedule these exact changes to the future Fedora release while keeping already implemented ones.
  • Contingency deadline: N/A
  • Blocks release? N/A
  • Blocks product? N/A

Documentation

Release Notes

Erlang/OTP 23.0 is available in Fedora 33.