From Fedora Project Wiki
Line 98: Line 98:
 
== Upgrade/compatibility impact ==
 
== Upgrade/compatibility impact ==
  
This will affect people updating.  A solution has not been confirmed yet.
+
As nodejs library packages are removed, we will work with the various packages that depend on them.  We will help them bundle their nodejs libraries.
 +
To help people updating we will utilize the fedora-obsolete-packagesIt will obsolete all the various nodejs libraries that are removed, and allow people to do updates to Fedora 34.
 +
 
 
<!-- What happens to systems that have had a previous versions of Fedora installed and are updated to the version containing this change? Will anything require manual configuration or data migration? Will any existing functionality be no longer supported? -->
 
<!-- What happens to systems that have had a previous versions of Fedora installed and are updated to the version containing this change? Will anything require manual configuration or data migration? Will any existing functionality be no longer supported? -->
  

Revision as of 20:29, 28 September 2020

Idea.png
Guidance
For details on how to fill out this form, see the documentation.


Stop Shipping Individual Nodejs Library Packages

Summary

For Nodejs, Fedora should only package:

  • The interpreter, development headers/libraries, and the assorted tools to manage project-level installations (NPM, yarn, etc.).
  • Packages that provide binaries that users would want to use in their shell.
  • compiled/binary nodejs modules (for now)

Owner

Current status

  • Targeted release: Fedora 34
  • Last updated: 2020-09-28
  • FESCo issue: <will be assigned by the Wrangler>
  • Tracker bug: <will be assigned by the Wrangler>
  • Release notes tracker: <will be assigned by the Wrangler>

Detailed Description

The nodejs libraries have been approved to be bundled, and there is infrastructure in place for the bundling to work properly. Currently, it is recommended that packagers should create individual nodejs library packages instead of bundling all of the libraries into the package requiring them. This change is to make it default to bundle the nodejs libraries with the package that needs then, and retire the vast majority of nodejs library packages.

In summary, for Nodejs Fedora should only package:

  • The interpreter, development headers/libraries, and the assorted tools to manage project-level installations (NPM, yarn, etc.).
  • Packages that provide binaries that users would want to use in their shell.
  • compiled/binary nodejs modules (for now)


Feedback

There has been a discussion on the fedora nodejs mailing list about what to do with the extreme dependency problem of the nodejs library packages. Because of the extreme inter-dependency, upgrading almost any package causes others to break. It has caused most packages to rot, un-upgraded for years. Many of the nodejs packagers are giving up and orphaning their packages, which has caused even more problems.

An initial proposal was to find all of the important nodejs library packages and bundle those, making them easier to upgrade and maintain. But there was problems with figuring out what was important, and what versions should those have. During that discussion this rather extreme solution, of getting rid of all nodejs libraries was proposed. To our surprise, it has been the best suggestion and fixes the most problems.

Benefit to Fedora

  • In Fedora 33, there are many nodejs libraries that are uninstallable, causing other programs based off them, to also be uninstallable. This get's rid of that problem.
  • Packages in Fedora that use nodejs libraries will be able to use the library versions that upstream has tested and approved.
  • If a package in Fedora uses a nodejs library, the packager will not have to also package extra individual nodejs library packages. There have been times this has led to over 100 extra packages, each with their own package reviews and maintenance problems. This change will lower the workload on that packager, and possibly get more packages into Fedora.
  • The nodejs maintainers can concentrate on nodejs itself, instead of the whole nodejs library infrastructure.

Scope

  • Proposal owners:
  • Other developers: N/A (not a System Wide Change)
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)


  • Alignment with Objectives:

Upgrade/compatibility impact

As nodejs library packages are removed, we will work with the various packages that depend on them. We will help them bundle their nodejs libraries. To help people updating we will utilize the fedora-obsolete-packages. It will obsolete all the various nodejs libraries that are removed, and allow people to do updates to Fedora 34.


How To Test

  • Install all nodejs libraries in Fedora 33. Try to update to Fedora 34.
  • Try to install all packages that require nodejs in Fedora 34.
  • Install all packages that require nodejs in Fedora 33. Try to update to Fedora 34.

User Experience

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: (What to do? Who will do it?) N/A (not a System Wide Change)
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? N/A (not a System Wide Change), Yes/No
  • Blocks product? product

Documentation

N/A (not a System Wide Change)

Release Notes