From Fedora Project Wiki

Line 8: Line 8:
 
== State ==
 
== State ==
  
Jeroen has put up a number of things:
+
[[User:Kanarip|Jeroen van Meeuwen]] has put up a number of things:
  
Git repo with specfiles: git://fedorapeople.org/home/fedora/kanarip/public_git/ruby-specs.git <br/>
+
* Koji: http://koji.ergo.project.org, with the following tags and repositories:
Git repo for Ruby itself: git://fedorapeople.org/home/fedora/kanarip/public_git/ruby.git <br/>
+
** Enterprise Linux 5 with Ruby 1.9.1:
[http://www.kanarip.com/custom Yum repos with test builds for Ruby 1.9] and a [http://mirror.nl.kanarip.com/custom mirror]
+
*** [http://koji.ergo-project.org/koji/taginfo?tagID=53 base] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el5-ruby-1.9.1/ repository]
 +
*** [http://koji.ergo-project.org/koji/taginfo?tagID=62 updates] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el5-ruby-1.9.1-updates/ repository]
 +
*** [http://koji.ergo-project.org/koji/taginfo?tagID=64 updates-testing] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el5-ruby-1.9.1-updates-testing/ repository]
 +
** Enterprise Linux 6 (Beta) with Ruby 1.9.1:
 +
*** [http://koji.ergo-project.org/koji/taginfo?tagID=71 base] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el6-ruby-1.9.1/ repository]
 +
*** [http://koji.ergo-project.org/koji/taginfo?tagID=72 updates] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el6-ruby-1.9.1-updates/ repository]
 +
*** [http://koji.ergo-project.org/koji/taginfo?tagID=74 updates-testing] koji tag and [http://mirror.nl.ergo-project.org/repositories/custom-el6-ruby-1.9.1-updates-testing/ repository]
 +
** Fedora 11 with Ruby 1.9.1 (coming soon)
 +
** Fedora 12 with Ruby 1.9.1 (coming soon)
 +
 
 +
Also:
 +
 
 +
* Git repo with specfiles: git://fedorapeople.org/home/fedora/kanarip/public_git/ruby-specs.git
 +
* Git repo for Ruby itself: git://fedorapeople.org/home/fedora/kanarip/public_git/ruby.git
  
 
== Tasks ==
 
== Tasks ==

Revision as of 12:52, 30 April 2010

Plan

Jeroen posted a draft plan. There are two big buckets of items:

  • Get Ruby 1.9 built/packaged, as well as rebuilding a sufficient number of ruby packages
  • Decide whether supporting both 1.9 and 1.8 is necessary and worthwhile

State

Jeroen van Meeuwen has put up a number of things:

Also:

Tasks

Interpreter

  • Get Ruby 1.9.x built
  • Settle on a load path
  • Rebuild all rubygem-* and ruby-* packages against 1.9 and file bugs for failures

Ruby packaging

  • Settle on a ruby.macros for RPM
  • Draft changes to the packaging guidelines
    • ruby(abi) vs. ruby(api)
    • install into vendor lib rather than site lib