From Fedora Project Wiki
Line 4: Line 4:
 
|389-ds-base || X || GPLv3+ || '''depends on libdb-devel''' || nothing yet planned
 
|389-ds-base || X || GPLv3+ || '''depends on libdb-devel''' || nothing yet planned
 
|-
 
|-
|apr-util || X || ASL 2.0 || optional module || configure --without-berkeley-db
+
|apr-util || X || ASL 2.0 || uses libdb for its dbm || can use gdbm instead, configure --without-berkeley-db
 
|-
 
|-
|bind || X || MPLv2.0 || depends on libdb-devel ||
+
|bind || X || MPLv2.0 || bind-sdb uses libdb for db backend support || can use postgresql, ldap, sqlite and dirdb instead
 
|-
 
|-
|bogofilter || X || GPLv2 || depends on libdb-devel ||
+
|bogofilter || X || GPLv2 || uses libdb for datastore || can use qdbm, TokyoCabinet, sqlite
 
|-
 
|-
|clisp || || GPLv2 || Build without the bdb module ||
+
|clisp || || GPLv2 || includes a interface module for libdb || Build without the bdb module
 
|- style="color: green;"
 
|- style="color: green;"
 
|cyrus-imapd || X || BSD || does not depend on libdb-devel anymore since f26  ||
 
|cyrus-imapd || X || BSD || does not depend on libdb-devel anymore since f26  ||
Line 16: Line 16:
 
|cyrus-sasl || X || BSD with advertising || uses libdb for sasldb || can use ndbm or gdbm instead, lmdb support in devel
 
|cyrus-sasl || X || BSD with advertising || uses libdb for sasldb || can use ndbm or gdbm instead, lmdb support in devel
 
|-
 
|-
|dsniff || || BSD || '''Depends on libdb-devel''' || last release - Dec 2000
+
|dsniff || || BSD || Uses libdb to store records about intercepted packages || '''no alternatives''', last release - Dec 2000
 
|-
 
|-
|evolution-data-server || X || LGPLv2+ || Part of the addressbook depends on libdb || configure --without-libdb, migrated to SQLite?
+
|evolution-data-server || X || LGPLv2+ || Part of the addressbook depends on libdb, deprecated in favour of sqlite || cmake -DWITH_LIBDB=OFF
 
|-
 
|-
 
|exim || || GPLv2+ || depends on perl || can be used with other DBM libraries (gdbm, tdb)
 
|exim || || GPLv2+ || depends on perl || can be used with other DBM libraries (gdbm, tdb)
Line 24: Line 24:
 
|hail || || GPLv2 || '''depends on libdb-devel, upstream dead?''' ||
 
|hail || || GPLv2 || '''depends on libdb-devel, upstream dead?''' ||
 
|-
 
|-
|heimdal || || BSD nad MIT || || configure --without-berkeley-db, use LMDB
+
|heimdal || || BSD and MIT || backend support for Heimdal kdc and kadmind || configure --without-berkeley-db, use LMDB or NDBM
 
|-
 
|-
 
|httpd || || ASL 2.0 || depends on apr-util-devel || Use apr-util-devel compiled without BDB
 
|httpd || || ASL 2.0 || depends on apr-util-devel || Use apr-util-devel compiled without BDB
Line 32: Line 32:
 
|iproute || X || GPLv2+ and Public Domain || '''arpd binary depends on libdb-devel''' || build without arpd (patch the config script) or rewrite it to use something else
 
|iproute || X || GPLv2+ and Public Domain || '''arpd binary depends on libdb-devel''' || build without arpd (patch the config script) or rewrite it to use something else
 
|-
 
|-
|ipv6calc || || GPLv2 || '''depends on libdb-devel''' || contacted upstream, probable change to LMDB. Needs '''perl-LMDB_File''' in Fedora/EPEL
+
|ipv6calc || || GPLv2 || depends on libdb-devel || contacted upstream, probable change to LMDB. Needs '''perl-LMDB_File''' in Fedora/EPEL
 
|-
 
|-
|isync || || GPLv2+ || depends on libdb-devel || libdb an optional dependency, mdconvert for backward compatibility with libdb
+
|isync || || GPLv2+ || libdb an optional dependency || mdconvert for backward compatibility with libdb
 
|-
 
|-
|jabberd || || GPLv2+ || depends on libdb-devel ||  
+
|jabberd || || GPLv2+ || uses libdb as one of its backends for storage + authentication || can also use MySQL and Postgresql
 
|-
 
|-
|jigdo || || GPLv2 with exceptions || uses libdb for file cache || configure --without-libdb
+
|jigdo || || GPLv2 with exceptions || uses libdb for file cache || '''no alternatives''', configure --without-libdb
 
|-
 
|-
 
|libapreq2 || || ASL 2.0 || depends on perl-devel, apr-util-devel, httpd-devel ||
 
|libapreq2 || || ASL 2.0 || depends on perl-devel, apr-util-devel, httpd-devel ||

Revision as of 11:27, 21 September 2017

Package RHEL License Dependency status Changes needed
389-ds-base X GPLv3+ depends on libdb-devel nothing yet planned
apr-util X ASL 2.0 uses libdb for its dbm can use gdbm instead, configure --without-berkeley-db
bind X MPLv2.0 bind-sdb uses libdb for db backend support can use postgresql, ldap, sqlite and dirdb instead
bogofilter X GPLv2 uses libdb for datastore can use qdbm, TokyoCabinet, sqlite
clisp GPLv2 includes a interface module for libdb Build without the bdb module
cyrus-imapd X BSD does not depend on libdb-devel anymore since f26
cyrus-sasl X BSD with advertising uses libdb for sasldb can use ndbm or gdbm instead, lmdb support in devel
dsniff BSD Uses libdb to store records about intercepted packages no alternatives, last release - Dec 2000
evolution-data-server X LGPLv2+ Part of the addressbook depends on libdb, deprecated in favour of sqlite cmake -DWITH_LIBDB=OFF
exim GPLv2+ depends on perl can be used with other DBM libraries (gdbm, tdb)
hail GPLv2 depends on libdb-devel, upstream dead?
heimdal BSD and MIT backend support for Heimdal kdc and kadmind configure --without-berkeley-db, use LMDB or NDBM
httpd ASL 2.0 depends on apr-util-devel Use apr-util-devel compiled without BDB
httpd-itk ASL 2.0 Use httpd-devel compiled without BDB
iproute X GPLv2+ and Public Domain arpd binary depends on libdb-devel build without arpd (patch the config script) or rewrite it to use something else
ipv6calc GPLv2 depends on libdb-devel contacted upstream, probable change to LMDB. Needs perl-LMDB_File in Fedora/EPEL
isync GPLv2+ libdb an optional dependency mdconvert for backward compatibility with libdb
jabberd GPLv2+ uses libdb as one of its backends for storage + authentication can also use MySQL and Postgresql
jigdo GPLv2 with exceptions uses libdb for file cache no alternatives, configure --without-libdb
libapreq2 ASL 2.0 depends on perl-devel, apr-util-devel, httpd-devel
libdb BSD Drop the package :)
libetpan BSD configure --disable-db
libgda LGPLv2+ configure --without-bdb
libpinyin X GPLv3+ depends on KyotoCabinet since f24
libserf ASL 2.0 depends on apr-util-devel Use apr-util-devel compiled without BDB
libsolv X BSD depends on libdb-devel because of rpm build rpm without libdb-devel, rewrite to accomodate for rpmlib changes
libzhuyin dead.package
lizardfs GPLv3 and ASL 2.0 and Boost depends on libdb-devel possibly none needed (due to GPLv3)
mod_gnutls ASL 2.0 depends on apr-util-devel Use apr-util-devel compiled without BDB
mod_security ASL 2.0 depends on httpd-devel Use httpd-devel compiled without BDB
nmh BSD can be used with gdbm
nss_updatedb GPL+ depends on libdb-devel required compatibility with nss_db (uses the same DB file)
nvi BSD depends on libdb-devel
open-cobol dead.package
opendkim BSD and Sendmail configure --without-db --with-lmdb -> Use LMDB
openldap X OpenLDAP libdb used for deprecated backends configure --disable-bdb --disable-hdb -> use LMDB
opensips GPLv2+ has a module for Berkeley DB exclude db_berkeley from built modules
pam X BSD and GPLv2+ pam_userdb module for auth against Berkeley DB configure --disable-db to disable bdb support
pam_abl GPLv2+ depends on libdb-devel
pam_ccreds GPL+ depends on libdb-devel upstream open to patches for alternatives
perdition GPLv2+ can use other alternatives, GDBM by default configure --disable-bdb to disable building with libdb support
perl-BDB GPL+ or Artisti dropping the package
perl-BerkeleyDB GPL+ or Artisti dropping the package
perl-DB_File X GPL+ or Artisti dropping the package
perl-Digest-MD4 GPL+ or Artisti depends on libdb-devel?
perl-eperl GPL+ or Artisti depends on libdb-devel
perl-Qt GPLv2+ and (GPL+ or Artistic) depends on perl-devel
php X MIT php-dba module can use libdb build without supporting libdb
pl lots of licenses depends on libdb-devel
postfix X IBM and GPLv2+ can use LMDB CCARGS="${CCARGS} -DNO_DB -DHAS_LMDB" AUXLIBS_LMDB="-llmdb"
python2 X Python deprecated bsddb module build python without the bsddb module
python3-bsddb3 BSD BDB bindings drop the package
qpid-cpp ASL 2.0 depends on libdb-cxx-devel don't have anything planned yet
rapidsvn GPLv3+ depends on apr-util-devel, openldap-devel build the packages without libdb
redland X LGPLv2+ or ASL 2.0 uses libdb for storage configure --without-bdb, can use relational DBs as a store
reprepro GPLv2 and GPLv2+ and MIT depends on libdb-devel being ported to SQLite
rpm X depends on libdb-devel upstream added LMDB backend via ed9de199
rsvndump GPLv3+ depends on subversion-devel build subversion without libdb
sendmail X Sendmail uses libdb for email aliases should be able to be built with QDBM instead
sks GPLv2+ depends on libdb-devel no plan to migrate in the near future
spamprobe QPL depends on libdb-devel, can be used with gdbm?
squid X GPLv2+ and (LGPLv2+ and MIT and BSD and Public Domain) external acl helpers (session, time_quota) use libdb rewrite/drop the helpers?
squidGuard GPLv2 depends on libdb-devel
subversion X ASL 2.0 uses libdb for repositories configure --without-berkeley-db, need to convert BDB repositories to FSFS
tabled dead.package
trustedqsl BSD depends on libdb-devel will add LMDB in its next release, drop BDB in release after that
webalizer GPLv2+ depends on libdb-devel without libdb -> DNS/GeoDB code disabled, upstream dead
xemacs GPLv3+ possibly none needed, can be built without supporting libdb
zinnia BSD build without libdb?