From Fedora Project Wiki
(Created page with "= Move deprecated bluetooth utilities to subpackage = == Summary == Move deprecated bluez bluetooth utilities to a sub package to indicate their status. == Owner == * Name:...")
 
Line 5: Line 5:
  
 
== Owner ==
 
== Owner ==
* Name: [[User:pbrobinson| Peter Robinson]], [[User:puiterwijk | Patrick Uiterwijk]]
+
* Name: [[User:pbrobinson| Peter Robinson]]
* Email: [mailto:pbrobinson@gmail.com| pbrobinson@gmail.com], [mailto:patrick@puiterwijk.org | patrick@puiterwijk.org]
+
* Email: [mailto:pbrobinson@fedoraproject.org| pbrobinson@fedoraproject.org]
 
* Release notes owner: <!--- To be assigned by docs team [[User:FASAccountName| Release notes owner name]] <email address> -->
 
* Release notes owner: <!--- To be assigned by docs team [[User:FASAccountName| Release notes owner name]] <email address> -->
 
<!--- UNCOMMENT only for Changes with assigned Shepherd (by FESCo)
 
<!--- UNCOMMENT only for Changes with assigned Shepherd (by FESCo)

Revision as of 09:00, 19 September 2020

Move deprecated bluetooth utilities to subpackage

Summary

Move deprecated bluez bluetooth utilities to a sub package to indicate their status.

Owner

Current status

  • Targeted release: Fedora 34
  • Last updated: 2020-09-19
  • FESCo issue:
  • Tracker bug:
  • Release Notes tracker:

Detailed Description

There's a number of utilities in the upstream bluez bluetooth package that have long been deprecated with their functionality replaced by the core bluetoothctl utility. They're no longer receiving updates and at some point may be removed. Move these utilities to a dedicated sub package to indicate their upstream support status.

Benefit to Fedora

Users are aware of the status of the various bluez utilities and why they may not support newer bluetooth functionality.

Scope

  • Proposal owners:
    • Create a sub package for deprecated bluetooth utilities, that is installed on upgrade, but not installed by default on new installs.
  • Other developers:
    • No impact
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

The new sub package will be installed on upgrade if bluez is installed, the deprecated utilities sub package will not be installed by default on a new install but will be available in the package repository.

How To Test

Check the new package is installed on upgrade, check the new package isn't installed for new installs

User Experience

Users shouldn't notice any difference, these utilities aren't used by standard bluetooth integration into desktops such as mice/keyboards/audio. They are command line utilities and bluetoothctl has superseded them and generally supports more functionality and newer reversions of the bluetooth spec.

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: N/A it's a straight fowrard packaging change.
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? No.
  • Blocks product? No.

Documentation

N/A (not a System Wide Change)

Release Notes

N/A