From Fedora Project Wiki
Line 53: Line 53:
 
|Update to 1.8.1
 
|Update to 1.8.1
 
|{{result||jstribny}} <!-- [bug_url number] -->
 
|{{result||jstribny}} <!-- [bug_url number] -->
 +
|-
 +
|rubygem-rb-inotify
 +
|Update to 0.9.5
 +
|{{result|pass|jstribny}} [https://bugzilla.redhat.com/show_bug.cgi?id=894705 894705] <!-- [bug_url number] -->
 +
|-
 +
|rubygem-listen
 +
|Update to 2.7.9
 +
|{{result|pass|jstribny}} [https://bugzilla.redhat.com/show_bug.cgi?id=853781 853781] <!-- [bug_url number] -->
 +
|-
 +
|rubygem-childprocess
 +
|Update to 0.5.3
 +
|{{result|pass|jstribny}} [https://bugzilla.redhat.com/show_bug.cgi?id=1060098 1060098] <!-- [bug_url number] -->
 
|}
 
|}
  

Revision as of 15:11, 7 October 2014

Vagrant

Summary

Provide Vagrant http://www.vagrantup.com/ with the libvirt provider as a default.

Owner

Contributors

Current status

Detailed Description

Vagrant is an automation tool used to manage development environments using virtualization and configuration management tools. It allows developers and teams to work on their projects and test them in an environment similar to production. Historically, Vagrant had a dependency on VirtualBox, but the newer versions have a plugin system allowing it to work with other virtualization technologies, including libvirt. The plan is to package Vagrant with the support for libvirt (coming as vagrant-libvirt plugin) replacing VirtualBox as a default provider.

Benefit to Fedora

Vagrant is widely used by development teams and is also used to provide pre-built environments by a lot of open-source projects. It would be a good addition to the Fedora development toolchain. Also providing a functional Vagrant package with libvirt provider as a default will help Fedora users to leverage libvirt instead of VirtualBox which is not part of Fedora.

Scope

Initial work has been done in for Vagrant on F20 in a Copr repository. Patches and quick fixes should be cleaned up or revisited. Also we need to depend on newer version of libvirt through rubygem-fog. Some commits for that are already in upstream repositories for vagrant-libvirt and fog.

Package name Task Status
rubygem-hashicorp-checkpoint Create 1150152
rubygem-log4r Create 1150151
rubygem-json Update to 1.8.1
rubygem-rb-inotify Update to 0.9.5
Pass pass jstribny
894705
rubygem-listen Update to 2.7.9
Pass pass jstribny
853781
rubygem-childprocess Update to 0.5.3
Pass pass jstribny
1060098

Upgrade/compatibility impact

N/A (not a System Wide Change)

How To Test

N/A (not a System Wide Change)

User Experience

N/A (not a System Wide Change)

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: (What to do? Who will do it?) N/A (not a System Wide Change)
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? N/A (not a System Wide Change), Yes/No

Documentation

N/A (not a System Wide Change)

Release Notes