From Fedora Project Wiki
(Done.)
m (lasso done)
 
Line 74: Line 74:
 
=== Items in Progress ===
 
=== Items in Progress ===
  
* Rebuilt Perl packages: 3114 of 3124 done (99.67 %)
+
* Rebuilt Perl packages: 3115 of 3124 done (99.71 %)
* Failed builds (9):  
+
* Failed builds (8):  
 
** bionetgen - [https://bugzilla.redhat.com/show_bug.cgi?id=1511600 BZ#1511600]
 
** bionetgen - [https://bugzilla.redhat.com/show_bug.cgi?id=1511600 BZ#1511600]
 
** dnssec-tools - [https://bugzilla.redhat.com/show_bug.cgi?id=1381613 BZ#1381613 ]
 
** dnssec-tools - [https://bugzilla.redhat.com/show_bug.cgi?id=1381613 BZ#1381613 ]
 
** kgb-bot - [https://bugzilla.redhat.com/show_bug.cgi?id=1581161 BZ#1581161]
 
** kgb-bot - [https://bugzilla.redhat.com/show_bug.cgi?id=1581161 BZ#1581161]
** lasso -  [https://bugzilla.redhat.com/show_bug.cgi?id=1598047 BZ#1598047]
 
 
** liboping - [https://bugzilla.redhat.com/show_bug.cgi?id=1542544 BZ#1542544]
 
** liboping - [https://bugzilla.redhat.com/show_bug.cgi?id=1542544 BZ#1542544]
 
** libspf2 - [https://bugzilla.redhat.com/show_bug.cgi?id=1594191 BZ#1594191]
 
** libspf2 - [https://bugzilla.redhat.com/show_bug.cgi?id=1594191 BZ#1594191]

Latest revision as of 10:35, 9 July 2018


Perl 5.28

Summary

A new perl 5.28 version brings a lot of changes done over a year of development. Perl 5.28 was released 6/23/2018. See 5.28.0 perldelta for more details about preparing release.

Owner

Current Status

Completed Items

  • Upstream to release Perl 5.28
  • Get dedicated build-root from rel-engs (f29-perl)
  • Define perl_bootstrap in perl-srpm-macros
  • Rebase perl to 5.28.0
  • Build new perl 5.28 keeping old COMPAT Provides
  • Rebuild dual-lived packages (otherwise dnf recommends --skip-broken and fails)
  • Rebuild packages needed for minimal build-root
  • Rebuild packages needed for building source packages from git repository
  • Remove old perl(:MODULE_COMPAT_5.26.*) from perl
  • Undefine perl_bootstrap
  • Rebuild other packages: Use Fedora::Rebuild dependency solver
  • Rebuild packages having perl_bootstrap condition in spec file
  • Rebuild all updated packages
  • Merge dedicated build-root to rawhide and remove the dedicated one by rel-engs
  • Synchronize packages upgraded in f29 build root

Items in Progress

Items to Be Done

Detailed Description

New perl is released every year and updates containing mainly bug fixes follow during the year. The 5.28.0 version is stable release this year.

Benefit to Fedora

Up-to-date and latest perl release will be delivered to Fedora users.

Scope

Every Perl package will be rebuilt in a dedicated f29-perl build-root against perl 5.28.0 and then if no major problem emerges the packages will be merged back to f29 build-root.

  • Proposal owners:

New perl and all packages requiring perl or a Perl module will be rebuilt into f29-perl build-root.

  • Other developers: N/A (not a System Wide Change)

Owners of packages that fail to rebuild, mainly perl-sig users, will be asked using Bugzilla to fix or remove their packages from the distribution.

  • Release engineering: #7509 (a check of an impact with Release Engineering is needed)

Release engineers will be asked for new f29-perl build-root inheriting from f29 build-root. After successful finishing the rebuild, they will be asked to merge f29-perl packages back to f29 build-root.

  • Policies and guidelines:

No policies have to be modified to complete this change.

Upgrade/Compatibility Impact

Vast majority of functionality will be preserved. Only the packages that failed to build against perl 5.28 will be removed from the distribution. That will require to remove those packages from existing systems otherwise package manager will encounter unsatisfied dependencies.

How to Test

Try upgrading from Fedora 28 to 29. Try some Perl application to verify they work as expected. Try embedded perl in slapd or snmpd.

User Experience

There should not be any remarkable change in user experience.

Dependencies

There is more than 3100 packages depending on perl. Most of them are expected not to break. Finishing this change can be endangered only by critical changes in a toolchain.

Contingency Plan

If we find perl 5.28 is not suitable for Fedora 29, we will revert back to perl 5.26 and we drop the temporary build-root with already rebuilt packages.

  • Contingency deadline: branching Fedora 29 from Rawhide.
  • Blocks release? No.

Documentation

Release Notes

Important Changes

  • Unicode 10 is supported
  • Mixed scripts can be detected with regular expressions easily now (Unicode TR#39)
  • In-place file editing is safer
  • delete operator works on slices
  • Large i-node numbers are provided as strings now
  • File descriptors are opened with a close-on-exec flag now
  • Locale switching is thread-safe now
  • Some operations on Unicode strings are faster

Removed Features and Incompatible Changes

  • Subroutine attributes must precede subroutine signatures
  • Comma-less variable lists in formats are no longer allowed
  • :locked and :uniq attributes have been removed
  • Opening the same symbol as a file and as a directory handle is not allowed anymore
  • Bare << here-document operator is not allowed anymore
  • Unicode code points with a value bigger than IV_MAX are not allowed
  • AUTOLOAD cannot be inherited to non-methods anymore
  • sort pragma does not allow specifying sort algorithm anymore
  • B::OP::terse() subroutine was replaced by B::Concise::b_terse()
  • Non-XS and non-exported subroutines are not represented as typeglobs anymore
  • Yada-yada operator (...) is a statement now, it cannot be used as an expression
  • unpackstring() and unpack_str() functions now return SSize_t type

Deprecated Features

  • vec function is deprecated on Unicode code points above 0xFF
  • Use of an unescaped left brace immediately after an opening parenthesis (({) is deprecated in regular expressions
  • Assignment to $[ variable is deprecated
  • Passing arguments to Sys::Hostname::hostname() is deprecated