From Fedora Project Wiki

< SIGs‎ | SciTech

(→‎Optional - GUI: Package data into table)
(→‎Scilab 5.2: fix dead link)
Line 26: Line 26:
 
Scilab 5.2.0 has been released in December 2009, however this has created some new java dependencies that must be packaged to fully implement Scilab functionality.
 
Scilab 5.2.0 has been released in December 2009, however this has created some new java dependencies that must be packaged to fully implement Scilab functionality.
  
A preliminary SRPM is available  [http://dhd.selfip.com/427e/untested/scilab-5.2.0-1.beta1.fc10.src.rpm here].
+
A preliminary SPEC can be found [http://mycae.fedorapeople.org/SPECS/ here].
  
 
=== Optional - GUI ===
 
=== Optional - GUI ===

Revision as of 16:26, 8 September 2010

Introduction

Scilab is a package that provides a numerical analysis environment with a friendly graphical interface. This page provides information specific to the packaging of scilab for fedora as well as some of the dependencies that are currently unavailable through yum.

Status

A Scilab RPM has been proposed in Bugzilla (Bug 472639). This has not yet been approved and is awaiting several dependencies. The Scilab binary has been successfully built (locally) without online help, PVM or Matio.

Packaging

Scilab is currently not available in the fedora repositories, as a result of incomplete dependencies required for basic functionality. Notably a working jogl and gluegen RPM has not been generated to date (Nov. 2009). Several other packages for optional functionality are also not available.

Requirements

Scilab 5.1

To build a functional GUI, the following packages are required, these are not available in fedora repos at this time. These dependencies are listed below.

Java GUI

Optional functionality

  • PVM -- PVM provides distributed computing functionality, this is obviously desirable in a numerical analysis package. PVM libraries are in the fedora repos. The .spec file provided with the scilab review request includes some (commented out) patches for PVM building, however these are incomplete as linker errors are caused during the build process. The patches for PVM are available here.

Scilab 5.2

Scilab 5.2.0 has been released in December 2009, however this has created some new java dependencies that must be packaged to fully implement Scilab functionality.

A preliminary SPEC can be found here.

Optional - GUI

Again, although optional a GUI is almost essential to basic scilab usage.

  • jgraphx - Jgraphx is a graph (edge + vertcies) library for java (package review) This package is required for the XCos functionality in Scilab
  • hdf-java - (http://www.hdfgroup.org/hdf-java-html/index.html) Hdf-java is an HDF reading interface into java, this is optionally required for Scilab HDF5 functionality and for XCos.

The following archives are not mandatory packages for hdf-java. They just extends hdfview features.

  • FITS - FITS java library. (mycae: I am unclear where the original home project for this is. There appears to be at least some projects here: http://fits.gsfc.nasa.gov/fits_libraries.html)
  • net-cdf-java - (http://www.unidata.ucar.edu/software/netcdf-java/) This itself has a many java dependencies, many which are not available. Some may need to be checked for legal concerns. A quick examination of included .jar files in this projects "source" distribution shows the following might be required for packaging:
JAR file(s) Fedora package Comment
bounce-0.14.jar
casclient-2.1.1.jar [1]
catalina.jar tomcat5
commons-fileupload-1.2.1.jar jakarta-commons-fileupload
ehcache-1.6.0-beta3.jar [2]
je-3.3.62.jar [3], different from db4-java
jpeg-1.0.jar, jpeg2000.jar
jstl.jar jakarta-taglibs-standard (this one might do) [4]
lucene-core-2.3.2.jar lucene
slf4j-jdk14-1.5.6.jar, slf4j-log4j12-1.5.6.jar slf4j [5]
spring-2.5.jar, spring-test-2.5.jar, spring-webmvc-2.5.jar [6]
standard.jar
stax-api-1.0.1.jar bea-stax [7]
wstx-lgpl-3.2.5.jar bea-stax (this one might do) [8]