From Fedora Project Wiki

m (→‎Wed Nov 5 18:30:08 UTC 2008: squashfs followup)
m (Question for Rmyers7)
 
(4 intermediate revisions by one other user not shown)
Line 1: Line 1:
= Trouble running script =
+
== Can't self install on XO ==
 
 
== Wed Nov  5 17:29:00 UTC 2008 ==
 
  
 
I recently purchase a Sandisk SD card to try to do the Fedora 10 installation on my XO. I could not follow the installation instructions as I have an older SD card reader that will not recognize the 4Gb SDHC card.
 
I recently purchase a Sandisk SD card to try to do the Fedora 10 installation on my XO. I could not follow the installation instructions as I have an older SD card reader that will not recognize the 4Gb SDHC card.
Line 41: Line 39:
 
</pre>
 
</pre>
  
Any work arounds, or do I have to go out and get a SDHC reader?
+
User:jlaska - suggested to
[[User:Rmyers7|Rmyers7]] 17:29, 5 November 2008 (UTC)
 
rmyers7 at mindspring dot com
 
 
 
=== a little follow-up ===
 
The following is now on the SD card:
 
* the volume name I set with mkfs.msdos
 
* /.olpc.store directory and contents (not relevant to this, but shows card is ok)
 
* empty /LiveOS directory
 
* /syslinux directory with ldlinux.sys in it
 
 
 
Should the live image simply be copied to /LiveOS? I've never done this before, so I don't know what correct looks like. [[User:Rmyers7|Rmyers7]]
 
 
 
== Wed Nov  5 18:30:08 UTC 2008 ==
 
 
 
[[User:jlaska]] - To address the ''No such file messages'' it appears you'll need to install some missing packages.  Try: <pre># yum install isomd5sum squashfs-tools</pre>
 
 
 
Also, what type of system are you running the script on (Fedora8, Fedora9, Fedora10)?
 
 
 
 
 
Thanks for the response. I'll try that. I saw the isomd5sum error, but as it seemed to me just to be just a warning for the checksum, I  ignored it. I'm trying this on an XO with build 767, which is Fedora 9. My other linux box is Fedora 8. I'm going to try to do the  installation on a 2Gb SD card on the Fedora 8 box. If that succeeds at least I'll know what success looks like. I didn't try this before as the 2Gb card I have handy is formatted ext2. But I looked at the script and see that it works with ext[23] as well as fat. [[User:Rmyers7|Rmyers7]]
 
 
 
I did the installs and behavior changed, but I still get errors. I'm now trying to more fully understand the installation script to figure out where the issue is. However, I'm trying another tack - with its own issues. See my other section 'Am I missing something?' [[User:Rmyers7|Rmyers7]]
 
 
 
Probing deeper in the script. It seems to be failing on trying to mount a squashfs image. I loaded the squashfs-tools, but I suspect that the real issue is that the XO doesn't have squashfs support compiled in. As such I figure that we can't self install. I guess its a a trip to the local BB tomorrow to see if I can find a SDHC reader. [[User:Rmyers7|Rmyers7]]
 
 
 
== Am I missing something? ==
 
  
I'm trying to get this going. My current tack is not quite following the script, so I don't know if that is the issue. However, I get to a point where there seems to be some information missing here.
+
# yum install isomd5sum squashfs-tools
  
===What I did/where I'm at===
+
Which I did. This did not resolve the 'No such File' errors. Probing deeper in the script, it seems to be failing on trying to mount a squashfs image. I loaded the squashfs-tools, but I suspect that the real issue is that the XO doesn't have squashfs support compiled in.  
I don't have a SDHC reader, and haven't run out to get one yet.  I'm trying to do the install on a 2Gb slow SD card, just as a proof of concept. The card is formatted ext2, and has about 200Mb on it that I chose not to scrag - as the info here implies that the card need not be dedicated.
 
  
I ran the livecd script and the final results were a filled SD card with a 1.7G image at /LiveOS/ext3fs.img. Is this correct - does the image fill all available space, or did I run out on a 2G card?
+
<code>21:40, 8 November 2008 (UTC)</code> - [[User:Rmyers7|Rmyers7]]
 +
* So the bottom line is that you can't uses an XO to self install this image.
  
The XO has a developer key and security is disabled.
+
<code>Mon Nov 10 12:43:02 UTC 2008</code> - [[User:jlaska]]
 +
# What OS and version are you running the script on? 
 +
# Any <code>/var/log/audit/audit.log</code> or <code>/var/log/messages</code> error messages appear when running the script.
  
===Something missing===
+
== Is anybody successfully using the Nov 4th build? ==
So now I have a card with an image (good???). If I insert it and on powering up, the XO simply powers up normally. If I interrupt the boot, there doesn't seem to be anything to point to for an alternate boot. 'boot sd:\LiveOS\ext3fs.img' doesn't work. There are no instructions here as to how to actually start the F10 image. How does one get into it? [[User:Rmyers7|Rmyers7]] 00:14, 6 November 2008 (UTC)
 
  
=== self answered ===
+
I have successfully loaded and use the Snap3 build. I installed the Preview build and the XO does not complete the boot. The comet freezes near the bottom of the screen during its second revolution after going slower and slower. The sunspot animation continues, but the machine never gets any farther. [[User:Rmyers7|Rmyers7]] 21:49, 8 November 2008 (UTC)
Image is not good because we ran out of space.
 
  
The unsquashed image is 3Gb, so it looks like about 3.6Gb is needed to install. However the livecd script doesn't report a problem because the squashed size is 700Mb, givving a bougs guess of 1.3GB needed.
+
== Warning about dual boot failure ==
  
And because the image never completed, the forth boot file never gets copied.
+
After interrupting the boot process with the escape key, so that I could boot into Sugar (boot nand:\boot\olpc.fth) rather than the F10 test, the XO refuses to boot into F10 on subsequent boot attempts. It gets as far as the boot message on the XO power up screen, but never proceeds into the Fedora boot process screen. I suspect that this is a manifestation of 461808. I suspect that something in the normal XO boot or operation is corrupting the F10 initrd. So for right now it looks like if you want to use your XO for F10 and Sugar, you need to remove the F10 card, and not boot to Sugar with it in. IMO, this is '''not''' a good long term situation, as discussion in the OLPC community suggests that the SD slot does not stand up to mishandling, and unnecessary insertion/removal cycles are to be avoided. [[User:Rmyers7|Rmyers7]] 22:04, 8 November 2008 (UTC)

Latest revision as of 12:48, 10 November 2008

Can't self install on XO

I recently purchase a Sandisk SD card to try to do the Fedora 10 installation on my XO. I could not follow the installation instructions as I have an older SD card reader that will not recognize the 4Gb SDHC card.

So, I tried to do a self installation procedure on the XO. I copied the F10 live image to a USB stick, and inserted it and the SD card in thee XO. I downloaded the live iso script and attempted to run it. This failed with lots of 'no such file or directory' errors. The 'already set up' error is because this log was a second attempt, so that I could capture the log. Log follows:

bash-3.2# bash livecd-iso-to-disk.sh --xo --overlay-size-mb 320 --swap-size-mb 256 /media/PNY4/Fedora-10-Snap3-i686-Live/F10-Snap3-i686-Live.iso /dev/mmcblk0p1
Verifying image...
livecd-iso-to-disk.sh: line 304: checkisomd5: command not found
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort
y
Already set up as live image.
Deleting old OS in fifteen seconds...
Copying live image to USB stick
mount: unknown filesystem type 'squashfs'
cp: cannot stat `/media/cdtmp.1T1vVo/LiveOS/ext3fs.img': No such file or directory
Cleaning up to exit...
umount: /media/cdtmp.1T1vVo: not mounted
umount: /media/cdtmp.1T1vVo: not mounted
cp: cannot stat `/media/cdtmp.1T1vVo/isolinux/*': No such file or directory
Updating boot config file
sed: can't read /media/usbdev.CifSx0/syslinux/isolinux.cfg: No such file or directory
Initializing persistent overlay file
dd: opening `/media/usbdev.CifSx0/LiveOS/overlay-SAN4fedora-4911-BF89': No such file or directory
sed: can't read /media/usbdev.CifSx0/syslinux/isolinux.cfg: No such file or directory
sed: can't read /media/usbdev.CifSx0/syslinux/isolinux.cfg: No such file or directory
Initializing swap file
dd: opening `/media/usbdev.CifSx0/LiveOS/swap.img': No such file or directory
/media/usbdev.CifSx0/LiveOS/swap.img: No such file or directory
Setting up /boot/olpc.fth file
egrep: /media/usbdev.CifSx0/syslinux/isolinux.cfg: No such file or directory
Installing boot loader
mv: cannot stat `/media/usbdev.CifSx0/syslinux/isolinux.cfg': No such file or directory
umount: /media/cdtmp.1T1vVo: not mounted
umount: /media/usbdev.CifSx0: not mounted
USB stick set up as live image!

User:jlaska - suggested to

  1. yum install isomd5sum squashfs-tools

Which I did. This did not resolve the 'No such File' errors. Probing deeper in the script, it seems to be failing on trying to mount a squashfs image. I loaded the squashfs-tools, but I suspect that the real issue is that the XO doesn't have squashfs support compiled in.

21:40, 8 November 2008 (UTC) - Rmyers7

  • So the bottom line is that you can't uses an XO to self install this image.

Mon Nov 10 12:43:02 UTC 2008 - User:jlaska

  1. What OS and version are you running the script on?
  2. Any /var/log/audit/audit.log or /var/log/messages error messages appear when running the script.

Is anybody successfully using the Nov 4th build?

I have successfully loaded and use the Snap3 build. I installed the Preview build and the XO does not complete the boot. The comet freezes near the bottom of the screen during its second revolution after going slower and slower. The sunspot animation continues, but the machine never gets any farther. Rmyers7 21:49, 8 November 2008 (UTC)

Warning about dual boot failure

After interrupting the boot process with the escape key, so that I could boot into Sugar (boot nand:\boot\olpc.fth) rather than the F10 test, the XO refuses to boot into F10 on subsequent boot attempts. It gets as far as the boot message on the XO power up screen, but never proceeds into the Fedora boot process screen. I suspect that this is a manifestation of 461808. I suspect that something in the normal XO boot or operation is corrupting the F10 initrd. So for right now it looks like if you want to use your XO for F10 and Sugar, you need to remove the F10 card, and not boot to Sugar with it in. IMO, this is not a good long term situation, as discussion in the OLPC community suggests that the SD slot does not stand up to mishandling, and unnecessary insertion/removal cycles are to be avoided. Rmyers7 22:04, 8 November 2008 (UTC)