From Fedora Project Wiki
(Add prefix)
(Ask about v8 and ruby as packages in platform for rails)
 
(2 intermediate revisions by 2 users not shown)
Line 33: Line 33:
 
* fdr-rails3.2-rails
 
* fdr-rails3.2-rails
  
= v83.1.4 =
+
{{admon/question|What about the required SCLs?  fdr-v8_3.14 and fdr-ruby1.9.3?}}
 +
 
 +
= v8_3.14 =
 
Maintainer Name - mmaslano@redhat.com
 
Maintainer Name - mmaslano@redhat.com
  
Line 43: Line 45:
  
 
== Packages in the Platform ==
 
== Packages in the Platform ==
* fdr-v83.1.4
+
* fdr-v8_3.14
* fdr-v83.1.4-v8
+
* fdr-v8_3.14-v8

Latest revision as of 16:44, 26 June 2014

ruby1.9.3

Names

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.

Packages in the Platform

  • fdr-ruby1.9.3
  • fdr-ruby1.9.3-ruby

Compatibility Guarantees

No changes are planned. Only new patchsets fixing serious bugs can be applied. Ruby is releasing patchset instead of minor bugfix release.

rails3.2

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.

Packages in the Platform

  • fdr-rails3.2
  • fdr-rails3.2-rails
Questionmark.png
What about the required SCLs? fdr-v8_3.14 and fdr-ruby1.9.3?

v8_3.14

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

The v8 collection is used just only to support execution of javascripts. Usually is used v8. The rails3.2 SCL is tested with this precise version.

Packages in the Platform

  • fdr-v8_3.14
  • fdr-v8_3.14-v8