From Fedora Project Wiki
(dots in name)
Line 1: Line 1:
= ruby193 =
+
= ruby1.9.3 =
  
 
== Names ==
 
== Names ==
Line 9: Line 9:
 
== Detailed Description ==
 
== Detailed Description ==
  
Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby193 collection split into ruby193 SCL and railsX SCL. Be careful if your application is using ruby193 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.
+
Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.
  
 
== Packages in the Platform ==
 
== Packages in the Platform ==
  
ruby193
+
ruby1.9.3
  
ruby193-ruby
+
ruby1.9.3-ruby
  
 
== Compatibility Guarantees ==
 
== Compatibility Guarantees ==
Line 21: Line 21:
 
No changes are planned. Only new patchsets fixing serious bugs can be applied. Ruby is releasing patchset instead of minor bugfix release.
 
No changes are planned. Only new patchsets fixing serious bugs can be applied. Ruby is releasing patchset instead of minor bugfix release.
  
= rails32 =
+
= rails3.2 =
 
Maintainer Name - mmaslano@redhat.com
 
Maintainer Name - mmaslano@redhat.com
  
Line 28: Line 28:
 
== Detailed Description ==
 
== Detailed Description ==
  
Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby193 collection split into ruby193 SCL and railsX SCL. Be careful if your application is using ruby193 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.
+
Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.
  
 
== Packages in the Platform ==
 
== Packages in the Platform ==
rails32
+
rails3.2
  
= v8314 =
+
= v83.1.4 =
 
Maintainer Name - mmaslano@redhat.com
 
Maintainer Name - mmaslano@redhat.com
  
Line 40: Line 40:
 
== Detailed Description ==
 
== Detailed Description ==
  
The v8 collection is used just only to support execution of javascripts. Usually is used v8. The rails328 SCL is tested with this precise version.
+
The v8 collection is used just only to support execution of javascripts. Usually is used v8. The rails3.2 SCL is tested with this precise version.
  
 
== Packages in the Platform ==
 
== Packages in the Platform ==
v8314
+
v83.1.4
  
v8314-v8
+
v83.1.4-v8

Revision as of 16:41, 22 May 2014

ruby1.9.3

Names

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.

Packages in the Platform

ruby1.9.3

ruby1.9.3-ruby

Compatibility Guarantees

No changes are planned. Only new patchsets fixing serious bugs can be applied. Ruby is releasing patchset instead of minor bugfix release.

rails3.2

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

Main ruby package in version 1.9.3 from favourite SCL ruby193. According to Fedora guidelines was ruby1.9.3 collection split into ruby1.9.3 SCL and railsX SCL. Be careful if your application is using ruby1.9.3 SCL in EL releases, you might need to change your wrapper scripts (if you have any). For completely working collections you will also need v8 SCL, which is used only for execution of javascripts.

Packages in the Platform

rails3.2

v83.1.4

Maintainer Name - mmaslano@redhat.com

Maintainer2 Name - I need to persuade someone from Cloud who will use it

Detailed Description

The v8 collection is used just only to support execution of javascripts. Usually is used v8. The rails3.2 SCL is tested with this precise version.

Packages in the Platform

v83.1.4

v83.1.4-v8